We're upgrading

Be a part of the all-new
Nokia phones community,
coming soon.

Looking for the forum?


While we add the finishing touches to the new community, you can still browse the forum, but not create or edit posts.

Doesn't recive whatssapp messages when screen is sleeping.

Y does't recive any whatsapp messages when screen is sleeping, when i unlock the devices comes all messages.


Yes, i have that problem to, sometimes, i didn't receive whatsapp messages, but when i open the app, all new messages come. Im in nokia 5 TA-1053
I have same model.

What operating system are you folks using? (7.1.1, 7.1.2 or 8.0.0)


Whatsapp (v2.18.46) working ok here on 7.1.2

Android 8.0 oreo.

Same problem here on Oreo Stable - February patch V5.22A on TA-1053

When I do whatsapp calls, sometimes whatsapp is just getting closed while talking without any notification(killed by system, I guess)


WhatsApp worked fine on Oreo Beta.


I also discovered, that some apps other apps are closed while running in background. In particular, I was listening to an audiobook when it suddenly stopped playing and the app was killed.

Hi look in settings ...there can you set on. Apps and notifications...than you see notifications ;-) I have this problem on the 7.1 and in beta and go orea . Now works it good :)
I have the same problem, Oreo 8.1.0 on Whatsapp V 2.18.105 / no indication of new message, when phone opened and going into WhatsApp then only message suddenly appears
Go to setting tgen battery then go to BACKGROUND ACTIVATY MANAGER an check that whats app is on or not. If on then turn it off.
Same problem here on ta1053 oreo 8.1 . Battery optimization and background activity options are turned off for whatsapp. I've got the same problem with a few other apps(Spotify and audible. They just close after approx an hour of listening to music). The problem did not occur on oreo beta and nougat. It all began with oreo stable
Try to reset your app preference. It will help you
What exactly do you mean with app preference?
Go to setting then system then go to reset and select 2nd option thats called reset app preference. Reset it

Tech Wizard

Login to post a comment