The community forum

Join the conversation

Answered

Oreo 8.1 and Smart Lock

As I upgraded to 8.1, I noticed two days now that the Smart Lock menu does not work. is that a bug of the OS? Does anyone else has the same issue?

Best Answer

I had the exact same problem earlier on. I fixed it by doing this.

-Go to Settings -> Security & location -> Trust agents

-Disable Smart lock and enable it again

-Reboot.

Hope it works for you :)


For me it works. Can you point out what in the menu doesn't work, or is it the whole menu that's not working?

 When I enter the Smart lock menu with my pattern, all I get is a blanc white screen, with just the upper right menu for Help and About...

Answer

I had the exact same problem earlier on. I fixed it by doing this.

-Go to Settings -> Security & location -> Trust agents

-Disable Smart lock and enable it again

-Reboot.

Hope it works for you :)


2 people like this
Done! Thank you! Problem solved!

Only difference for me was to Disable Smart Lock, Reboot then Enable Smart Lock. I also opted out of the beta version of Google Play Services which didn't downgrade it anyway.

This is an Android bug which Google just seem to be ignoring. And, to make it worse, the May update has removed the Trusted Places option from Smart Lock altogether.

@Migs That's also a bug in Smart Lock as I have Trusted Places and I have the May update as well.

 Really? Because that's when it disappeared for me. I assumed they'd removed it. I'll check if the Trust Agent- Reboot trick works later. I hadn't thought to try it, as the rest of Smart Lock is there

Well, quite bizarrely, Trusted Places has reappeared. No reboot, no toggling the Trust Agent, nothing. I realised that it hadn't asked for fingerprint or pattern to unlock, checked Smart Lock, and there it is.

Login to post a comment