The community forum

Join the conversation

Bug with 5ghz wifi

Appear to have found quite a serious bug with 5ghz WiFi support. I'm the Oreo 8.1 stable router is a sky q router which supports both 2.4 & 5ghz WiFi. Both bands share the same SSID so devices can roam between 2.4ghz & 5ghz. The Nokia 8 however has a problem, it will happily roam over to the 2.4ghz band when the 5ghz band is out of range, however once it does this, it will favour the 2.4ghz band permanently and never roam back to the 5ghz band even if you sit the phone right on top of the router. In fact it can't even see the access point on the 5ghz band. All my other android and windows devices happily roam between both bands and will prefer the 5ghz band if it's in range. Only way to get the Nokia 8 to see the 5ghz band again is to toggle WiFi on and off. Afraid the majority of users won't be tech savvy enough to even notice this, but this is not working as it should. Please look at this so you can push a fix out in the next security patch.

This seems to have resolved itself after a few reboots, it seems to now be roaming quite happily between the 2 WiFi bands.

My Nokia 8 won't connect to 5Ghz WiFi. Can you explain how several reboots solved the issue?

The first place to start is make sure the 2.4GHz and 5GHz frequencies have separate SSIDs, it is well known that sharing SSIDs can cause more problems than it is worth.

If you have done that and you cannot see a 5GHz SSID then maybe the phone is faulty, i know it wont really bother to waste battery power scanning for a new access point when it is connected to a perfectly good one already but if you knock Wi-Fi off and back on again it should scan everything.

Different SSIDs are in place and visible :-)

 my case is that when knocking Wi-Fi off and back on while scan wireless networks 5GHz SSID are not listed.

I have tried, without success, changing the channel and channel width. WPAs encription and authentication methods, but nothing. even tried different routers.

No sucess! not even with phone in safe mode.

I don't know then my friend, maybe the phone is faulty after all.

I'm having a similar issue since the update. 5GHz is the preferred band, but it will only connect for about a second, and then defaults to 2.4GHz. If I delete the 2.4GHz network, it still drops the connection on 5GHz and stays unconnected. It's not a signal strength issue, as I can be on top of the router and the problem persists.

Definitely an update bug, I think, as wi-fi does work generally. I'll wait until the next update to see what happens.

Login to post a comment