The community forum

Join the conversation


I have recently purchased the Nokia 8 after updating it with the latest software on android (Oreo) i can't connect properly to my WiFi. I can connect but my phone's saying no internet is anyone having problems like this? Is there anything I can do to rectify this other than resetting my router or soft rest or hard as I've tried this and still nothing

I had the same problem and this is how I nailed down the issue.

Try and connect to a different WIFI router or a mobile hotspot. If you have a laptop with Windows 10, you can create a mobile hotspot. if your mobile can't connect, then try resetting the network settings or even the device for a fresh installation. If it cannot connect even then, send it for repairs.

However, If your phone connects fine to the hotspt, your phone is fine. It's the router.

This exact same thing happened with me. You might now ask why the router, every other device connects fine? 

True, every other device connects fine. Problem what I think is, this issue started after the december security update, not before that. My 2 cents say that in the december update there was a fix for the KRACK wifi issue. And your router might not have the similar fix. 

I ultimately had to change the router to a newer one even thought every other device works just fine. I moved from TP-Link Archer C20i (No KRACK fix) to a Netgear R6120 which has the KRACK fix. Now the phone connects fine.

This is most likely a router issue and not an issue with your phone. You need to login into your routers settings. If you are using multi-mode WiFi ie bg&n you need to disable short gi on the router or it will cause problems. If you can't disable short gi and you don't have any legacy WiFi devices on your network set the router to n only or AC wifi. If you are using 2.4ghz WiFi make sure the channel width is set to 20mhz otherwise you will get interference from your neighbours. To make sure you are using the best WiFi channel download WiFi analyser from the play store. With 2.4ghz WiFi you can only use channel 1, 6 & 11. Do nor set it to any other channel as they overlap and interfere. Also make sure you are using up to date security, you should set it to WPA2-PSK and set the encryption to AES.
Login to post a comment