The community forum

Join the conversation

Notifications on the lock screen

I've got a Nokia 3. My previous phone was an LG.


While with LG, If I had receive a message while the screen was locked, all I could read was something like this: "You have got a new message" (without showing who the message is from, neither the preview of the message, until I unlock the screen).


I would like that Nokia 3 had the option to hide the contact's name that sends me the message. Instead of clearly appearing "John" or whatever. I don't like other people to see who am I texting to, because people ask to many questions and I don't like to give any explanations on that topic.


Nokia either shows all, or shows nothing. It's too extreme. Will this issue be updated?


Hi user, Go to settings>Security and location>Lock screen preferences.and change it to hide sensitive notification.This is how to do on Android Oreo beta in Android Nougat it will have this but don't know whether it is in the same place.Hope this helps:-)

Hello. Thanks for the reply.

My phone's android version is the Nougat... I can't see the option to hide sensitive location... 


On the settings, I have the following options:

- "block all" - never show notifications

- "show silently" - don't make sound nor vibrate

- "replace the "don't bother" mode" - I don't know what that means...


I'm not sure if you mean "Security AND Location settings", like in a single menu, but I don't have that...

If I go to Security OR Locations settings, it does't show any options to hide sensitive notifications. I don't see any options related to lock screen notifications. 


If I select: "blockt all", it does't vibrate, so I'm unable to know if I have a new message. Have to check it by myself. It's annoying.


In the same day I posted this topic, I saw an YouTube video with an android phone that specifically had the option: "hide sensitive notification", but I don't know the android version of the phone in the video. But I know I can't find that option on Nokia 3.


Thanks again for the reply.

Go to settings/ apps and notification/ notification/ on the lock screen/ hide sensitive notification content

Just now, I went to notification settings. On the menu that says "all apps", I selected the option "without confidential content on the lock screen", but it says "without apps", which made me think that pherhaps, the SMS app is not associated to that option.


But there's a gear on the top of the screen in that menu. If I tap it, the menu "configure notifications appears", and it has a sub-menu named "on the lock screen". When I tap it, it shows two options: "don't show notifications", and "show all notifications".


I hope I found the correct option. I have to wait to receive a message from someone to see what happens. If the phone vibrates without showing the notification on the lock screen, then, it's solved.


Thanks for the reply.

It's solved. The SMS notifications doesn't appear with the screen locked and the phone vibrates when I receive the messages.


Before I create this topic, I went to settings/ apps/ SMS/ block all, and it really stays blocked, because it doesn't even vibrate. But with the steps on the previous reply, it works.


I appeciate your suggestions.

Login to post a comment