The community forum

Join the conversation

Unable to change voicemail speed dial number

 Hello


I took delivery of a new SIM Free version of this phone on Wednesday.


I charged the phone and booted it without a SIM, connected to my Wi-Fi at home and let it apply the Oreo update and then the March Security patch.


I placed a SIM in and booted fine and all is well except the voicemail number seems to be fixed to 905 and I need to change it.


I firstly tried to change to 443 which was the number for the service provider I was then on but it rejected the change with the message to contact my operator.


I tried a full reset of the phone but to no avail.


I'm in the process of moving provider and put the new SIM in tonght, the phone has not picked up the new voicemail number (901) from the SIM still won't allow me to change it.


I was using giffgaff which is a UK MVNO (running off O2) and am switching to O2.


Contacted HMD through the web chat and they just referred me back to the operator, considering the phone is SIM free they aren't likely to help that much, I did say that to the support person but that didn't seem to sway them.


Anyone had this issue on a UK version of this handset with stock firmware (not operator branded) and fixed it?


Booting without the SIM just gives the section title voicemail with no options.







2 people have this question

HMD are correct to refer you to the network for support on this. It's part of the SIM config, which the network can change via a service message. I had the identical issue myself, but just ignored it for a while (24 hours, or thereabouts), and it magically fixed itself (I think when automatic processes on the network noticed the new IMEI). Network support should be able to force a config update if need be.
Same problem on Nokia 6 (2017) on GiffGaff. Unfortunately the suggested solution by Murphy does not happen. There is no network supplied config update. Checked with Giffgaff and they say it is not the Sim as it changes correctly with other manufacturers phones to 443, just a problem with Nokia phones (I did check this on a Motorola and Samsung phone, and is correct for them at least). Maybe they both need to talk to each other to fix the problem instead of just playing blame ping pong!

Any more news on this?   We have bought 5 Nokia 5s with the intention of buying another 11 but not proceeding until this bug is sorted.  I have spoken to O2 and they are adamant that it is a Nokia issue.

Nothing has changed. Still a problem. Only an issue with Giffgaff which operates on the O2 network, O2 number is OK. I have just setup the Giffgaff voicemail number as another contact an use that when I see the VM icon message. Message icon disappears once VM has been accessed. Minor workaround, just irritating that Nokia & Giffgaff can't sort it out between them by talking instead of going into blame ping pong, as I said before.

Interesting that your O2 number is OK, as we are on O2 and having the issue. I have not had the problem on a Samsung Phone, the voicemail was not set automatically but I could change the default. I wonder if it is something silly like Nokia have locked changing the number and O2 have messed up encoding the Voicemail number on the SIM? Agree, I wish they would talk rather than just point the customer at the other party.

Just to be clear the O2 VM number I have fixed in my Nokia 6 is 901 which is the UK O2 VM number.

That makes it even funnier.  I have 905 which is the Tesco Mobile VM number. I want 901!

Does sound like someones lookup table is wrong somewhere. If both Tesco and Giffgaff are wrong it suggests Nokia to me.

 Right update


I have been in e-mail communication with 'Nokia Mobile Care'


I was asked to try a different non O2 SIM.


I obtained and inserted an EE PAYG SIM and booted the phone, I checked and the correct voicemail number +447953222222 was configured for voicemail speed dial so it suggests the phone is either not able to read it from the SIM on O2/Giffgaff SIMs or is looking up the information in a lookup table when logging on but it is wrong.


Went back to 'Nokia Mobile Care' with my findings and waited, the next mail I got suggested they were trying to close the case.


I quote below


Dear Mr.Techtamer,

This is Nokia Mobile Care.

 

We are glad to hear that now the the voice number is the correct one with the new SIM provider EE.

Would it be there anything else that we may assist with?

 

Should there be, please let us know!

 

Kind regards,

Nokia Mobile Care



I replied as follows

The issue is not resolved.

 

I was asked to do this as a test and I am feeding back on the results of that test.

 

When I reinsert my O2 SIM the number goes back to 905 which is incorrect and cannot be changed.



I received the following response

Dear Mr. Techtamer,

Thank you for your reply.

 

As the test with EE has shown, this is a provider issue connected to o2 and it's daughter company giffgaff.

 

The issue has been escalated and we hope that with the help of o2 it will be fixed soon.

 

However, for the moment being we cannot help further.

 

If you have further questions, please feel free to contact us again.

 

Best regards,

 

Nokia Mobile Care team

322458:566912

I'm not holding my breath on this.

Considering the somewhat dodgy English in the responses above as well as the fact the phone's firmware has a China Standard Time (CST) timestamp on it I'm beginning to wonder if the folks from Espoo actually have anything to do with the support of their product or if it's completely handed off to Foxconn (yes I know they manufacture hardware for a lot of brands).

Just for info, the phone has been updated to 8.1 and has the May security patch, I have also tried clearing the cache for phone and carrier services.

I'm just glad I havem't had an issue that has caused me a major problem but in the UK the support application directs you back to place of purchase.

The hardware is very nice, it works well as a phone and the experience is slick but I'm afraid the service and support appears to be dire.


 Update for those interested.


I picked up my phone on Thursday morning just before heading out to work and saw a prompt to restart it to apply updated operator settings.


I agreed and the phone restarted.


Checked the voicemail number and it is now correctly set to 901.


I haven't tested with any other SIM but just out of interest I tried to edit the number and it still returns the error that it cannot be changed.



 Further update.


Giffgaff have improved their offer in terms of bundles so have gone back.


SIM in, boot up and prompt to reboot to apply operator settings.


Back to 905, should be 443 and is locked as before.


Why is this locked on a non-operator branded device and why don't you fix the issue, if you don't want to build a lookup table, unlock the setting so people can set it themselves.





Login to post a comment