The community forum

Join the conversation

Unable to change voicemail speed dial number


I took delivery of a new SIM Free version of this phone on Wednesday.

I charged the phone and booted it without a SIM, connected to my Wi-Fi at home and let it apply the Oreo update and then the March Security patch.

I placed a SIM in and booted fine and all is well except the voicemail number seems to be fixed to 905 and I need to change it.

I firstly tried to change to 443 which was the number for the service provider I was then on but it rejected the change with the message to contact my operator.

I tried a full reset of the phone but to no avail.

I'm in the process of moving provider and put the new SIM in tonght, the phone has not picked up the new voicemail number (901) from the SIM still won't allow me to change it.

I was using giffgaff which is a UK MVNO (running off O2) and am switching to O2.

Contacted HMD through the web chat and they just referred me back to the operator, considering the phone is SIM free they aren't likely to help that much, I did say that to the support person but that didn't seem to sway them.

Anyone had this issue on a UK version of this handset with stock firmware (not operator branded) and fixed it?

Booting without the SIM just gives the section title voicemail with no options.

2 people have this question

HMD are correct to refer you to the network for support on this. It's part of the SIM config, which the network can change via a service message. I had the identical issue myself, but just ignored it for a while (24 hours, or thereabouts), and it magically fixed itself (I think when automatic processes on the network noticed the new IMEI). Network support should be able to force a config update if need be.
Same problem on Nokia 6 (2017) on GiffGaff. Unfortunately the suggested solution by Murphy does not happen. There is no network supplied config update. Checked with Giffgaff and they say it is not the Sim as it changes correctly with other manufacturers phones to 443, just a problem with Nokia phones (I did check this on a Motorola and Samsung phone, and is correct for them at least). Maybe they both need to talk to each other to fix the problem instead of just playing blame ping pong!
Login to post a comment