The community forum

Join the conversation

Still no Oreo on my Nokia 6 TA-1033 UK running on EE

I still haven't received Oreo update on my phone and it's April and I've been waiting since February. Can someone help? I tried clearing data from the Google frameworks services thing and I still haven't received it. I even tried to remove my son and use an Indian VPN and nothing works. I'm on android 7.1.2

I have the same issue as you.still waiting for February security updates.its just taking so long for the update.i like the Nokia 6 it's a really good phone.im just getting fed up hearing everyone else is getting there updates.

1 person likes this
Agreed
I'm still stuck in the January 1 2018 patch
When I wrote "remove my son" my son, I meant remove my sim that was the autocorrect on the keyboard and I didn't realize sorry about that
Hopefully someone helps us. I will be very grateful for it
Wow I just found the fix...All you have to do is remove your sim card and the factory reset your phone...and wait a little bit and you receive Android Oreo 8.0 this just worked for me
Have you got your updates yet?
Login to post a comment