The community forum

Join the conversation

Wifi deactivating after screen lock

How can i deactivate this option? I need some apps with permanent internet acceas. 4g not turning off, but wifi always doing it.

In android 7 there was a options under wifi menu, cant find it now on oreo


There should be an option in the advanced section of wi-fi preferences to keep it active in sleep mode. It will cause faster battery usage.

Not in Oreo. And yes, i want more battery usage sometimes.

The option isn't there, or it doesn't work? I have the option on Oreo 8.0 on my 5 (TA-1024). I've not tested it, but it is certainly there.

Tech Wizard

Wi-Fi (and Bluetooth) should stay on all the time if enabled. The power drain is minimal, at least if the 'Open network notification' is turned off and 'Switch to mobile data automatically' is turned on.
The best power conserving option for my use is 'Do not disturb' mode, at 5% in 8 hours (overnight, on the table) with all radios, GPS, NFC etc. on.


My Nokia 6 had several annoying bugs after the Oreo update, with music playback stopping, Bluetooth turning itself off etc.
The only permanent solution was to factory reset the phone, then set it up fresh without restore of apps and data, and without automatically install my apps.


A less time consuming option, maybe worth a try in this case, also in Settings > Reset options = Reset Wi-Fi, mobile & Bluetooth


Keep Wi-Fi on is not an option that I can find in Android 8.1.


--
Hans

Login to post a comment