The community forum

Join the conversation

8.1 update and april patch

Hi, I have a Nokia ta-1053 dual sim and i still haven't received the april security patch and the Android 8.1 update. My operator is orange FR I'm worried because we're already mid may... Thanks you

1 person has this question

You are not alone. The TA-1024 is still stuck on 8.0 / March in the UK. Personally, I'm getting quite angry at Nokia, largely at their inexcusable lack of communication. There is no valid reason for failing to just tell us what the current status is, and when we can reasonably expect it. If it goes on for much longer, I may file a formal complaint with several relevant government agencies which have legal power to investigate and fine companies for anti-consumer behaviour.

1 person likes this

 Another UK user here, TA-1024  ( retail version unlocked) Android Version 8.0.0 Security patch level 1st March 2018

 it would appear that the updates have dried up.

My TA-1053 in Czech Republic (Vodafone CZ carrier) is also stuck in 8.0 security level 1st March 2018.


1 person likes this
The server has now offered me 8.1.0 with 1 April security patch. TA-1024 (no network lock, retail unit) on O2 UK. Build number 00WW_5_600. 1818.4 MB reported size. Installation was basically trouble free, after clearing some large caches on apps to free space for the download. Early signs are that things are generally working well on the new build. HMD, I'm still rather annoyed with your total lack of communication between announcing the release and your server eventually admitting that it exists; not good enough, and came close to a formal consumer rights complaint going to Her Majesty's Government.

1 person likes this

 My TA-1024 with UK 3 sim updated today from March 8.1. I got the April update, installed that - rebooted and then the May update came available. Installed and it gave the error that it hadn't installed but it had installed correctly. I cleared the framework cache and all is good to go.

     

IN UK, TA-1024. Have just updated to 8.1 (OK) then did next update and then all I can get is the [No command]. In recovery screen have tried (with SD & SIM cards out) reboot system, wipe cache & data then reboot, but still goes back to No command... Can I get something to load with adb (haven't used before..). Bought direct from Nokia.  Help..!

Hello user1521993911154, Thanks yes, I'd seen that post.. I didn't quite get pressing the home key as well, I tried but either it made no difference or I wasn't doing it right. I'd tried the Nokia support chat but their bad grammar meant that the instructions were hard to follow and in essence were doing what I'd already done. I could get into what I presume is the recovery screen and tried all I could; wiping cache, data/reset, system boot, graphics test all to no avail. I emailed Nokia support asking if they could send a file I could use with e.g. web, but they said they just do remote support. So I'm going to do a warranty return.. to Hungary (so the DHL label says) & two weeks .

Sounds like you have done as much as you can.  Sorry it didn't help.  Hope you get a replacement quickly!

I'm from Mexico and I have the Nokia TA-1027 with the security patch of March and I'm still waiting for the update to Android 8.1

I still haven't received any update so far. This is highly frustrating, since 8.1 has some useful new features that I would like to use.


I tried contacting Customer Support via Nokia Support app, but they haven't been able to tell me anything apart from the fact that updates are dependent on carrier...


Anyone else there who still haven't received the update?


1 person likes this

I don't have 8.1 on EE in the UK.


I guess if I take the SIM out and reboot the phone will then get the update as it won't be carrier restricted. The problem is that there may be a reason why it's being withheld and then I'll have problems using the phone with EE. Of course EE may just be slow in approving the update.

I have a Plusnet sim and they use use EE. I got the update after turning off and on again yesterday.

I didn't restart but I did just do a check for updates and the update is there now. I did restart a few days ago and the last auto check was on the 29th so it looks like it's just been cleared for EE.


Thanks for the heads up.

Login to post a comment