The community forum

Join the conversation

4G/mobile data not working after Oreo 8.1 update

Hi. My Nokia 7 worked OK with Oreo 8.0. Official 8.1 was updated 12.5, there was some download error at first but later download and installation went smoothly. After update phone does not connect 4g network and mobile data is not working with 2/3g so phone is pretty useless when out of WiFi. Checked APKs as well 4g recommended connection is choose. Resented also connection setting, no help. Any advices please?

7 people have this question

why my nokia dont get the update oreo 8.1? i have the nougat 7.1 !

This is a known issue, that should be fixed after installing June security update. If not, people succeeded to fix it like this: backup the phone, then reinitialize the phone and use the backup to restore it. 4G is then back.

Hi Xophedebx, thanks for the advice, June security didn't fix this so have been without 4g and mobile data since 8.1 update = well over month now. Before factory reset, can you allow link where this problem and fix is discussed, can't find anything using search?
In french here http://nokians.fr/2018/06/hmd-sen-fout-des-utilisateurs-du-nokia-7-plus-qui-sont-passes-chez-sosh/#comments But the carrier has also to fix something on the network.
Tnx, I checked all comments using translator and didn't saw anyone suggesting factory reset if June security does not help?
Hello, indeed, comment seems not to be there anymore.
Did anyone fix this issue?
Hi, no, it's same even after July security update.

 Hi,


Just received August security update and 4G and mobile data are working now, great even it takes 3 months to recover.

I received the August security update yesterday and it didn't fix anything! I still don't have the ability to activate VOLTE, I loose data connection when talking on the phone, I have terrible call quality, and I'm dropping calls constantly! @user1526288356736 what network are you using? Did you gain access to any new settings after the August security update to help you fix the problem?

 Hi,


I'm using Telia operator in Finland. I just install security update, restart phone and everything works like before 8.1/may security updates. No new settings or anything need to be set up, just install and restart. Also Nokia pro camera app is opening very fast.

Thanks for the reply @user1526288356736. I'll just have to keep waiting and hope the September security patch fixes the issue here in the US on MetroPCS' network.

I'm in Vietnam. I have 2 sim with 4G from Viettel and Vietnamobile Operator.
Viettel 4G supports LTE band 3 ( 1800Mhz) 
Vietnamobile 4G support LTE band 8 (900Mhz)

I find on GSM Arena that Nokia 7 support both Band 3 and Band 8.
But I can only use 4G of Vietnamobile, Viettel 4G can't be connected.

I think there is an issue with LTE Band 3 (!?) while China is provide 4G network with Band 3, 38, 39, 40, 41....


Mobile data is still unavailable after august update. Not with 2G, 3G or 4G. Also it looks like 4G just can't work without mobile data so it is not available even for calls. Strange thing is that 4G works after phone reboot for a short period of time and I can make a call but then it just switches to 3G

Login to post a comment