The community forum

Join the conversation

Bug: Factory reset deletes ringtones

Tested this behaviour on a Nokia 6 and a Nokia 8
Both on Anrdoid Oreo 8.1, May 2018 security patch applied.

Did a factory reset on both devices.  After setting up the phone again ringtone, notifications tone and alarm tone are all set to 'None'.
When I try to select something else then 'None' the device just gives an empty list.  All ringtones, notifications tones and alarm tones seem to be deleted by the factory reset.


Created bug at Google but bug isn't in the AOSP.  They suggested creating a bug report for Nokia:


https://issuetracker.google.com/issues/80088535


1 person has this question

Tech Wizard

Did you restore a backup or set up the phones fresh after the factory reset?


I tried both ways on my risk-willing Nokia 6 TA-1021 without being able to reproduce the issue.


There is still stuff missing and some preferences not set as it was before restoring the backup, but no issues regarding audible alerts and alarm tones, and the whole selection of tones is still there.
The fresh setup looks and sounds as expected.


I previously had issues where the restore of a backup resulted in a very nervous phone, so I still don't trust Google's backup/restore routines, but have to admit it worked better than expected this time...


Which variant (TA-????) is the phones, used in which country, and at which mobile operator, please - for somebody to maybe give it another try?


--
Hans


1 person likes this

I tried a fresh start an they are gone one both the Nokia 6 and Nokia 8.

The Nokia 8 is in for repair.  The Nokia 6 is a TA-1033

Tech Wizard

Thanks for feedback.
I'm puzzled why and how the same error hit two different phone models. Please let us know if the workshop explains it? (They may simply replace the phone).


This is where a recovery tool for consumers would be useful, to recover the phone into a known good condition and rule out firmware, OS and configuration issues. There is recovery tools for legacy Nokia Lumia and Symbian phones officially available for end users.


If the Nokia 6 is just sitting there anyway, and if you got the time, it may be worth trying the built-in recovery?


It can be tricky and some of the button presses is time sensitive.
Step by step:


Power off your phone.
Connect your phone to a charger.

"POWERED BY android" logo will appear, followed by the battery charging screen.

Hold VOLUME UP + POWER BUTTON for 10 seconds, release.

During the 10 seconds, your phone will power cycle, followed by the "POWERED BY android" logo, followed by an image of Bugdroid (Android robot) with the text "no command".
If you see the the NOKIA logo instead of Bugdroid, you released VOLUME UP + POWER BUTTON too early or too late. Start over.

From the "no command" screen, hold POWER BUTTON, tap VOLUME UP, release POWER BUTTON. This should take you into Recovery Mode.



2 people like this

I'm puzzeled aswell, but it seems I have a different version of the phone then you do. 
The 6 was purchased in Belgium, my Nokia 8 in the Netherlands


I wiped cache and factory resetted the phone from Recovery Mode, still no ringtones.


I'd love Nokia to release the images like Google did/does for the Nexus/Pixel line.

I'd be able to flash 8.0 back and would be able to supply more info about this issue and the battery drain issue i'm having:  https://community.phones.nokia.com/support/discussions/topics/7000025454


2 people like this

Tech Wizard

Thanks for trying and for your patience!

TA-1033 is a single-SIM variant where TA-1021 is dual-SIM. They support the same mobile frequency bands, and are both hardware updated when compared to the first TA-100x models for mainland China and Taiwan.


In the E.U. warranty claims are to be made at the point of sale, officially.
If in your shoes I would ask the shop (or mobile operator) where you bought the Nokia 8 for help with the Nokia 6 too.
Their affiliate workshop must be able to recovery flash the phone, then apply all Over The Air updates, factory reset the phone, and see if the issue persists.
- It is then up to the workshop to escalate the issue if needed.


There are numerous complaints in the forum regarding missing or unstable notifications, but you are so far the only I have seen report missing the default list of tones after factory resets.


I follow the thread to see what happens.


--
Hans


1 person likes this

Quick update:


I was talking to the telecom guy at my work about the issue and wanted to show him what was happening.  
I booted up the phone (normally only used for app testing) and went into the sound menu, only to see all ringtones present!


I have no idea what brought them back.  Can a faulty SIM be the cause?

Check this thread:  https://community.phones.nokia.com/support/discussions/topics/7000025454


1 person likes this
Login to post a comment