The community forum

Join the conversation

Wifi Problem in Oreo: NETWORK SELECTION DISABLED ASSOCIATION REJECTION

Hi guys, I'm a bit frustrated since I bought my Nokia 8 TA-1012.


[INTRO]

Besides the seller sent me a used phone, with an already opened screen, my real issue right now is with the Wifi.


My phone came from Israel and I'm using it in Brazil. 


The Android is in the 8.1 version, still waiting for the camera update.


[ISSUE]

I'm having huge problems with Wifi Networks, both 5GHz and 2,4GHz, where after some time connected, the phone will disconnect and give me the following message when I try to connect again:


NETWORK_SELECTION_DISABLED_ASSOCIATION_REJECTION = #


where # is a number counter that increments everytime the phone tries to reconnect.


All my other devices are working fine on my networks, including a Galaxy S7 Edge, a Moto X 2013, a Motorola Moto Z2 Play, my Nintendo Switch, PS3, notebooks and guest devices that come here.


[WHAT I TRIED ALREADY]


- setting a fixed IP in the router

- resetting the router configs to default

- clearing the phone cache and rebooting (solves temporarily)

- rebooting in safe mode (still happens)

- factory reset on the phone, install nothing and wait (still happens. Google Play Store is the first app to update)

- changing network from 2,4GHz to 5GHz

- changing networks channels and bands


[DISCOVERIES] 


I have enabled the Developer mode and the extended Wi-Fi registry, where I can see the error message mentioned above. I see that a score is set to the network and when this error happens, the score is set at ZERO.

I read that Pixels phones had a similar issue, but none of the information provided on different sites solved for me.


[END]


I'm waiting for the camera update and hoping to fix it bt that. But, what if it don't solve it?


Does anyone have any idea how to solve this?


Hi,


What is your router's security type? WEP or WPA?


I'm using WPA2/PSK. I've tested with WPA, WPA2 and WEP. It's all the same. The problem resides in my phone and not on the router. All other devices in my home can connect with no issues. Can I upload pictures in a comment? I have screen captures of the error message.

I've done a Full Wipe using the recovery menu and the problem still persists.


I've even set up a spare router TP-Link WR842ND that I have here, setting as if it is from Israel and still no solution.


After the disconnect, the Wifi vanishes from the phone and won't appear again.


Here are some screenshots from my phone: https://drive.google.com/drive/folders/19izD5vHCXYwBAUdyCzVjzG6lhLWNjAqE?usp=sharing

Login to post a comment