The community forum

Join the conversation

All incoming calls are unknown callers since june update

 Since june update all incoming calls are unknown numbers. Despite the fact that they are known in my contactlist and they are sending their caller-id.

Had contact with vodafone servicedesk and they confirm they have had multiple calls from nokia 7 plus customers with this problem.

Factory reset and network reset at vodafone did not help.



Update the contact app, newer version

 I have the most actual version of contact app. 2.7.3.196717324 from 17th may. There is no newer one.

Thanks for the suggestion.


I have the exact same problem: Nokia 7 plus, Vodafone (Netherlands) and all incomming callsare unknown since a couple of days. There is no newer contact app, as Appu stated. Vodafone did a netwerk reset for me, didn't help. Seems to be a problem at the phone's end.
Strange enough same problem here, but solved the problem on one of the 2 Nokia 7 plus devices by activating a new simcard in the vodafoneshop. The 2nd one has a new simcard as well, but the problem reproduces after an hour or so. Putting the simcard in an other device (htc) and than back in the 7 plus solves the problem again for another hour... Looks like the problem is back as soon as the Nokia makes a network refresh.

Yes, same problem here.


and there is still no answer on nokia, android etc. forum.


I tried my simcard in other phones, and there is works fine, it is the nokia thats  the problem.


Hope there is a solution soon.

Regards

This is the answer that i got from nokia custom care, but i dont think that it does anything.

I think this is the solution if your own caller id isnt working.


>Removed the SIM from the phone>Perform a soft reset (the Volume-up + power button pressed together for 15 seconds till it reboots to "power by android")>Re-inserted SIM/SD card
>Ran through all the various setup settings (set your Caller ID on by going to the Phone app>> 3 vertical dots on the upper right>> Settings>> Calls>> Additional settings>> Caller ID).

The same problem here in netherlands with vodafone.

>Removed the SIM from the phone>Perform a soft reset (the Volume-up + power button pressed together for 15 seconds till it reboots to "power by android")>Re-inserted SIM/SD card
>Ran through all the various setup settings (set your Caller ID on by going to the Phone app>> 3 vertical dots on the upper right>> Settings>> Calls>> Additional settings>> Caller ID).

had no effect, still the problem

I switch the card to simcard slot 2 and everthing works well

Tried that, still the same.........thanks for the replie


user1529343256895 yes i am also in the Netherlands with Vodafone....

hi all.


I have a temporary solution for it.


Disable 4g, and volte if you are using it, en only use 3g/2g network, then everything works fine.


I hope Nokia will come with a solution soon, so we can use the 4g(+) network again.


Regards,


John


2 people like this

Just got this phone for my wife a few days ago. Updated at first start, so got June update directly.

Was laughing at her since I thought she couldn't figure out how to turn on Caller id, but indeed. No way to turn it on (and I'm not going to reset a just newly installed phone, since that can't be the solution since it was brandnew and empty out of box before update).

But John's workaround works for now (thanks a lot for the tip. Saved me returning the phone right away), but I hope Nokia / Vodafone / Google / Santa Claus releases a fix soon, because it's ridiculous caller id isn't working on a brand new phone.

Also Vodafone on Dutch network. New Sim card as well.

user1529513412913


this morning i put the Phone on the 4g network again, and until now the caller id works fine.

Dont know for how long, but for now......


maybe this was the solution, switch network, lets wait and see.


I know that this problem occurs with other networks too, but everyone i speak about it has Vodafone.


regards


1 person likes this
Yes, this did the trick. Switched to 2g/3g in stead of automatic (4g). Then incomming calls showed. After a while I Switched back, and then it still kept showing incomming numbers. Has been working for 10 hours now. Tnx John!

3 people like this
Login to post a comment