The community forum

Join the conversation

Background notification/alarm issues

I've been using the 3.1 (US) for a couple of weeks and am having issues with the phone not triggering notifications from background apps. I first noticed this with Google Hangouts, where a new message would arrive in my browser but the notification on the phone would not fire. After opening Hangouts, the notification would be triggered. 


This pattern extended to a 3rd party alarm clock that I use (Alarm Clock Xtreme), which when set displays Androids "alarm set"  icon in the notification area. In this case, after some passage of time the icon will literally disappear. I missed one alarm like this before switching back to the native alarm clock (which seems to work just fine).


It seems as if something on this phone is stopping processes that normally run in the background. I've tried disabling battery optimization at both the per-app and OS level with no change. I've dug around the settings (to include, those under developer mode) and nothing else jumps out as being able to control these types of behavior. 


Is anyone else having trouble like this? I really want to like this phone, but this is a bit of a show stopper for me.


3 people have this question

Since the August update on the US version, things have gotten better about killing off background apps.  Not good, just better.  I can maybe keep one background application alive which is still unacceptable.  I'm waiting for others trying the uninstall of evenwell applications before I do it myself.

Someone somewhere has done a lot of the same work on a Nokia 2. Useful to cross-reference what is ok/not ok to delete:


https://forum.xda-developers.com/general/general/nokia-2-apps-safe-to-delete-t3783158

Am happy to report I've also had some success with the deleting of the com.evenwell packages. Never used adb before, but that's pretty easy. Bit tedious deleting the packages one by one but that could be scripted in future, if need be. I did my package removals in two phases:


1. Just removed some that I obviously didn't need, and others that mentioned battery or power. I probably removed only about a dozen packages. I'd read elsewhere that someone had removed just battery & power related evenwell packages, and had success with that. For me, after an afternoon's use I saw no difference in the phone. Dropbox, Twilight, etc. still getting killed off quickly & regularly.


In between 1 & 2 my bluetooth went from working fine to not working at all. Again.


2. Before I went out for the evening I sat and removed ALL the evenwell packages. Rebooted the phone (which also made bluetooth work again). I told Twilight to run, and Android duly showed it running in background. At the end of the evening ... it was still there! (And working). Went to bed ... still OK. Checked phone this morning ... STILL OK! Plus I'd received Words with Friends notifications, and my Twitter app (Tweetcaster) was showing notifications too.


Dropbox ... not 100% sure yet. It *might* still have been killed, but I need to play/test that some more to be sure. BUT, so far, BIG improvement. I expect to see a hit on battery levels as a result, but I don't expect it to be huge and is a price I'm willing to pay.

Disclaimer! I'm not suggesting anyone else to 'go for it' with the evenwell packages removal. Just saying, it worked for me. It involves an good amount of command-line typing, so be sure to be careful & accurate.

I can confirm that this problem exists on the US variant, and that removing all of the evenwell junk (except for the FM radio, which you'll probably want to keep) fixes it. Do note that the 'pm uninstall' operation is irreversible except by factory reset, so I suggest using 'pm disable-user com.evenwell.*' over adb instead.

1 person likes this

'pm disable' - good point, but too late for me I didn't research adb thoroughly enough realise that was an option... Good for others to know, and for me too for future. Thanks :)

*Update* My phone is SO much better now. Everything I want to run seems to be running. The thing that initially triggered this for me - Dropbox not uploading pictures - is amongst the things that seems to be quite happy now. Having not touched the Dropbox app for a couple of days (loading the app always started camera uploads working again), I've been taking pics, and they've all been uploading automatically.


Just one commend on the variation 'pm disable' rather than 'pm uninstall' - I'm not sure that 'pm disable' achieves the desired result. I'm trying to use this same method to speed up my old Asus TF300T tablet. I tried 'pm disable' for the PressReader app, which I never use. Checked the app list - still there, apparently not disabled. Tapped on the icon to load it - the app loaded fine, despite 'pm disable' saying it had been killed.

Hmm, just to confirm that is 'pm disable-user' not 'pm disable'. Looks like this after I kill an app: https://i.imgur.com/QKAECFG.png . A reboot afterwards wouldn't hurt, either. I'm certain this method works - I used it just after a factory reset and my apps are staying in the background now.
Hmm, just to confirm, that's 'pm disable-user' not 'pm disable'. Looks like this after I use it on a system app: https://i.imgur.com/QKAECFG.png . A reboot afterwards doesn't hurt, either. I'm positive this method works. I used it just after factory resetting my phone and all of my apps are staying in the background now.

@rman Thanks for that. Just to clarify, I'm not trying this on my TF300T, not my Nokia (so apologies for going off-topic) I've tried the both disable and uninstall the TF300T and at present neither has much effect... It may be that I'm not using adb correctly (though neither command returns an error message). I'll keep trying and Googling. Using adb on the Nokia, and now the TF300T, are my first forays into adb so I probably just need to read up some more.

Login to post a comment