The community forum

Join the conversation

GPS Problem

 Hi guys!

I experience some problems with the GPS on my Nokia phone with Oreo 8.1. This is how it looks like in the GPS Test app:

https://img1.picload.org/image/dlori...803-201912.png

I tried the following
- turned off the 4G
- also turned on/off the WiFi
- tried changing the location mode from high accuracy to device only
- cleared the AGPS - again no signal, then updated the AGPS, same thing
- restarted the phone
- turned off the phone, waited for a while, turned it on again
- removed the SIM card, waited for a while, put it in again

Google maps finds my location, also Runtastic but it says that GPS signal is weak and tracking will not work. So something is obviously wrong here. This happened before as well, then the GPS worked perfectly for about a week, now I have the problem again.


Can anybody please help? Thanks!


Mak, I have been experiencing the same problem & can be resolved only with a factory reset. Strangely the problem comes back with time. I guess it's a bug that needs to be resolved by hmd
Same here on Android P DP4. Every app which use location service can't find my location. But I can see my location using GPS testing tools app.
It's currently working for me on P DP4, had this constant GPS error on previous versions including 8.1

I rolled back to official release and currently working fine. Kinda miss P's gesture feature.  

Hi guys! I think I found a solution for my problem. Just do what this bloke here says. I also set the AGPS refresh in the app to 6 hours. Every time before using GPS with Google Maps, Runtastic, or another app I open GPS Status and wait for a fix. Haven't had a problem for the past 10 days. Sometimes it takes longer to get a fix, but hey, it works now.

@Makaox thanks mate, please do share the steps to refresh agps & open GPS status optio Thanks again

Hi mate, this is described in step 3. Just do everything that dude says. Here the link again: https://androidforums.com/threads/gps-fix-s5-dummies-guide.907733/


I set the AGPS download to 6 hours and that's it. Now I always first open the GPS Status app and wait for a fix. It usually takes between 2 seconds and 2 minutes. Then I start the app I need, e.g. Google Maps, and it works without any troubles.


I guess that in case the AGPS data is relatively new (a couple of days old or so) you don't even need to open GPS Status first. I have to test further to confirm.


I believe this is an Android problem. Too many phones with stock Android (Nokia, OnePlus, PIxel) have the same problem. There is something wrong with stock Android and AGPS, not sure what, hope Pie will work better. Anyway, this trick works for the moment, hope it stays like this.


Cheers!


1 person likes this
@Mak, thanks a ton for your time and helpful share __/\__ Cheers
Login to post a comment